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    Excel Quick Overview: 

Use of Excel, its boundaries & features. Kick off to practical session. 

How to open Microsoft Excel 2010/2013? 

By Menu: 

Start → All Programs → Microsoft Office → Excel 2010/2013 

By Command: 

Start → Run → Type Command (EXCEL) 

What is MS Excel? 

MS Excel is a spread sheet program use for perform high level calculation on data like filtration, sorting, 

 searching, etc. 

MS Word file is called “documentation” and its file consist number of Pages. 

But MS Excel file is called “Workbook” and its file consist number of sheets.  

In Office 2010/2013, MS excel file format is .xlsx 

What are Columns and Column Header? 

Vertical lines are called “Columns” in excel each column has specify name is called “Column Header”  

Like (A,B,C,……..Z,AA,AB,……….., XFD). 16384 columns in one sheet 

What are Rows and Row Header? 

Horizontal lines are called “Rows” in excel each row has specify name is called “row header” Like 

(1,2,3,……..99,100,………..1048576). 10,48,576 rows in one sheet  

What are cells and why we use name box? 

Intersection point of row and column is called “Cell” combination of column name and row  

name make “cell name” like Column A and Row 100 cell name A100 , you can see in 

 name box(Top left side).  

Name box use for go to specify cell or create name of selected cells  

What is sheet tab? 

In excel each sheet has specify name is called “Sheet tab” 

 we can change sheet name/ tab color or insert / delete sheet  

Right click on sheet tab  
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➢ Rename  
➢ Re-Name  
➢ Tab Color 
➢ Insert (Shift+F11) 
➢ Delete  
➢ Hide / Unhide  
➢ Move / Copy  

 

 

Difference between Sheet and Workbook 

 Combination of cells is called “Sheet” and Combination of sheets is called “Workbook” 

What are Operators? 

 Specify sign perform specify action are called “Operators” 

How many types of operator? 

 4 types of operator 

1. Arithmetic Operator: 
 

Sign Name Description 

+ Plus Use for addition just number values 

- Minus Use for Subtraction just number Values 

* Asterisk Multiplication between number values 

/ Forward slash Use for Davison 

% Percentage Gain Percentage Value 

^ Caret Exponentiation (create power) 

- Nagaition Minus values are called Nagition Values  

 

2. Logical (Comparison) operator: 
 

Sign Name 

= Equal  to  

> Grater than  

< Less than 

>= Grater than or equal to  

<= Less than or equal to   

<> Not equal to  
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Data formation in Excel in 

form of a Database 
Data in database shape is very important. Unless, it’s in proper shape your 

analysis will not work. We will help you understand data rules required to bring 

your data in a right state for analysis. Base data correctness is extremely 

important for a true analysis. Remember, database is garbage in garbage out. 

 

• Database is a collection of data stored in Rows & Columns. 

• Avoid keeping blank rows in Excel Data. It may create problems in results especially 

when we are using Pivot Tables, Data Filters, and Formulas etc. 

• Use lightweight functions as much as possible. Otherwise use paste special function. 

• Try avoid putting “space” or “-” in starting of the sentence. 

• Whenever you are going to compile, process your data, take backup before doing this.  

• Don’t save the actions on data until and unless you are sure that whatever you have done 

is ok. 

• When you are merging data of two tables, two databases through VLOOKUP etc., make 

sure minimum one field (column) of both tables, databases should be common. 

Steps to Create Series Using Series Dialog box  

Home -> Fill-> Series  
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Data formatting & custom 

settings 
An important exercise with the help of Excel in built features which is applied on available data 

to for number, text, date, day, month, year, currency settings. 

Excel Formatting - number formatting 

Number formatting refers to the addition of currency symbols, decimal markers, percent signs, 

and other symbols that help to identify the type of data present in a cell and to make it easier to 

read. 

Steps to Apply Number Formatting  

1) Select data table -> Right Click on the cell -> Choose Cell Formatting options or press 

Ctrl+1 Short cut key 
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Add Rs. Symbol using custom settings.  

 

Adding lakh Separator in MS Excel using custom settings  

Eg. 

10,23,876.00-- ##”,”##”,”###.00 

28/01/2012 – DD/MM/YYYY 

20-JAN-2012 –DD-MMM-YYYY 

Formatting a Table 

Excel provides several predefined table styles (also called quick styles) that you can use to quickly 
and easily format a table. Table styles include professional looking combinations of fill colors, fonts, 
borders, font colors and patterns. If none of the predefined table styles meet your needs, you can create 
your own custom styles. 

 

Table Styles are found on the contextual Design tab under Table Tools. The Ribbon displays only a 
few of the available styles. To scroll the style gallery, click the previous or next buttons. To display 
the entire table gallery, click the More button. 

You can further modify the formatting of your table by modifying table style options such as hiding 
or displaying the header row, adding special formatting to the first or last columns, or displaying 

http://pcmcourseware.com/blog/wp-content/uploads/2008/09/excel1.jpg
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banded rows or columns, in which the even rows or columns are formatting differently from the odd 
rows and columns, much like an accounting green bar report.  

To remove a table style, click the More button on the Table Styles group and choose Clear from the 

menu. The table will display in the default table format.  

To Format a Table 

1. Click anywhere within the table to activate it. 

2. Click the contextual Design tab under Table Tools on the Ribbon. 

3. Click the More button on the Table Styles group to display the styles gallery. 

4. Move your mouse pointer over any of the styles to display a preview of the style. 

5. Click the style that you want. 

6. To remove a table style, click the More button on the Table Styles group and click Clear on the 

menu. 

To Format Table Elements 

1. Click anywhere within the table to activate it. 

2. Click the contextual Design tab under Table Tools on the Ribbon. 

3. On the Table Options group, do one of the following: 

 a. To turn the header row on or off, select or clear the Header Row check box.  

 b. To display special formatting for the first or last column of the table, select the First  

             Column or Last Column check box. 

 c. To display odd and even rows with different formatting, select the Banded Rows 

             check box. 

 d. To display odd and even columns with different formatting, select the 

             Banded Columns check box. 

 e. To turn the totals row on or off, select or clear the Totals Row 

             check box. 

Conditional Formatting 
It will help you automate formatting of conditional results in such a way which is 

color coded and easy to see and understand. Once defined, Excel will 

automatically change the color of your values e.g. up or down, high or low, pass 

or fail, profit or loss etc. 
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Imagine you have a spreadsheet with thousands of rows of data. It would be extremely difficult to see 

patterns and trends just from examining the raw data. Excel gives us several tools that will make this 

task easier. One of these tools is called conditional formatting. With conditional formatting, you can apply 

formatting to one or more cells based on the value of the cell. You can highlight interesting or unusual 

cell values, and visualize the data using formatting such as data bars. Excel conditional formatting lets 

you change the appearance of a cell based on its value or the value of another cell. You specify certain 

conditions, and when those conditions are met, Excel applies the formatting that you choose. 

Why we need conditional formatting? 

You can use conditional formatting to locate dates that meet a certain (such as falling on a Saturday or 

Sunday), to call out highest or lowest value in a range, or to indicate values that fall under or over a 

specified amount. 

How to perform conditional formatting? 

You have many conditional formatting rules, or options, that you can apply to cells in your spreadsheet. 

Each rule will affect selected cells differently. Before you choose a formatting rule, you need to identify 

what questions you are trying to answer. For example, in a sales spreadsheet, you might want to identify 

the salespeople with lower than average sales. To do this, you need to choose a conditional formatting 

rule that will show you this answer. Not all the options will provide you with this information. 

Steps to create Conditional Formatting  

 

Adding Conditional Formatting to a Cell 

1. Select a cell or range of cells to be formatted. 
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2. Click on the Home tab-> Select Conditional Formatting -> Select Highlight Cell Rules -> Select 

Conditions  

3. Enter your conditions ->Select Color->ok   

 

 

 

 

Adding Customized Icon Sets 

Icon sets give you an opportunity to create visual effects 

in your data to see how the value of a cell compares with other cells. 

 

Excel 2016 offers several choices of icon sets. You can choose the icons that are most 

appropriate for the data you are using. Figure 1 shows the gallery of icons as well as the user 

interface (UI) to get to the icons. The Condition Formatting option is available on the Home 

tab. 
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.  

 

Red-Yellow-Green geometric icons applied to a range of data 
 

 

This is an example of a range of data with colored arrows in different directions, 

relative to the middle values in the range.  Arrows tend to indicate trends: 
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Colored arrows indicate direction relative to mid-range values 
 

 

 

Edit Icon Set Condition  

Home-> Conditional Formatting-> Manage Rules -> Edit Rule 

 

 
 

The next example shows five different categories grouped using a circle that ranges 

from empty through filled (like the phases of the moon or a pie chart): 

 

Apply Excel Conditional Formatting to a Row 

 

You can apply conditional formatting that checks the value in one cell, and applies 

formatting to other cells, based on that value. 

For example, you could colour the entire row in a table, if the values in column B are 

over a set value. In this example, we'll colour cells blue, if the number of units, in 

column B, is greater than 75. At a glance, we'll be able to see which dates have a high 

number of units. 
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Steps –> 

1) Select the data -> Home Tab->New Rule-> 

2) Select Use a Formula to determine which cells to Format.   

      3) Type Formula =$B2>100  

      4) Choose Format button ->select color -> OK  

 

 
 

Highlight Duplicate Records  

1) Select the Unique Column -> Home -> Conditional Formation-> Highlight Cells Rule -> Duplicate 

Values  

Filters, Queries selective selection of 

data 
 

You have bunch of data and you want to drill it down to your desired level based 

on multiple choices and conditions. We will explain all the steps so that you can 

produce results quickly with very little efforts 

 

Many times, rather than working with an entire table, you may wish to work with only a subset of 

your data. Using the Auto Filter feature, you can display only the records with which you wish 

to work and hide all others from view. 

AutoFilter is an easy way to turn the values in Excel column into specific filters based on the 

cell contents.  
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To turn on auto filter, 

1. Click any cell within your range. 

2. From the Data Tab, select Filter. 

Or Use Short Cut Kay Ctrl+Shift+L or Alt D F F  

Once you’ve enabled this feature, your columns display with a drop-down arrow to the right. If 

you click the arrow control, you’ll see all the values for that particular column. To turn off the 

feature, you deselect Auto filter from Filter tab. 
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In the example above, I can see all the entries that show in the City column. Various Cities are 

omitted such as Chennai, Kolkata, Delhi and Chennai that values aren’t represented on the 

spreadsheet. 

Excel Custom AutoFilters 

To set a simple custom auto filter, 

1. Enable auto filter for your spreadsheet using the steps in the section above. 

2. Click the down control arrow in the column you wish to filter. 

3. From the drop-down list select (Custom…) The Custom AutoFilter dialog opens. Your 
column name should show above the first list box. 

4. In the first list box, click the drop down arrow and select your criteria. 

5. In the list box to the right, either type a value or select one from the list. 

6. Click OK. 

In the example below, I’ve elected to filter for sales greater than 75000. 
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Excel is versatile in the filter settings. You’re not limited to just items containing a specific 
value. You could also use: 

• equals 

• does not equal 

• is greater than 

• is greater than or equal to 

• is less than 

• is less than or equal to 

• begins with 

• does not begin with 

• ends with 

• does not end with 

• contains 

• does not contain 

Sometimes you need a more complicated filter. For example, I may want to select a row if two 
conditions are met. I might also be interested in selecting a cell if one or another condition is 
met. 
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Now I got sales between 50,000 and 1,00,000 

Advanced Filter 

The Excel Advanced Filter can be used to perform more complex filtering than the basic Excel 

Auto filter  

Instead of filtering by fixed values or simple criteria, the advanced filter depends on user-

defined criteria that can be applied to several columns of data simultaneously. These criteria 

are specified on the same spreadsheet as the range to be filtered, rather than in the filter 

command box.  

In order to perform an Excel advanced filter, you need to specify a list_range and a 

criteria_range. These ranges both specify ranges of cells on your working spreadsheet. They 

are defined as:  

list_range - The range of cells that you want to filter. This range should include 
headers at the top of each column.  

criteria_range - A range of cells (generally positioned above or below the list_range), 
in which the filtering criteria are specified.  
 
The criteria_range should be headed by headers that match the 
list_range headings. The criteria for the corresponding rows in the 
list_range should be listed under each of these headings.  
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The Excel Advanced Filter is best explained by 
way of an example.  

The spreadsheet on the right shows the set-up 
for an Excel advanced filter on the range of 
cells A5 - D17 (the list_range)  

The Criteria to be used for the filter are listed in 
the cells B1 - D3 (the criteria_range)  

The first row of the criteria_range is the header 
row and the actual criteria are listed below this.  

Criteria listed on the same row are linked by the 
"AND" operator, and criteria listed on different 
rows are linked by the "OR" operator. 
Therefore, the criteria in the example translate 
to the condition:  

( Maths % >= 60 AND Science % >= 60 AND 
English % >=60 ) ORMaths % >=80 

 

 

Select the Data tab at the top of your spreadsheet and select Advanced from the Filter 
options.  

 

This causes the Excel Advanced Filter options box to pop up. This is the same in Excel 2003 
and Excel 2010/2013 and is shown on the right.  



 
 
 
 

21  
 

                               Practical Workbook of MS Excel  

As shown, in this example, the list_range should be input as A5:D17, and the criteria_range 
should be input as B1:D3 on the current worksheet.  

If you want to display the list in place, simply click OK. However, if you wish to copy the result 

of the filter into a new location, this can also be specified at this stage. 

 

The result of the Excel advanced filter is shown in the spreadsheet on the right. As expected the rows 

that have been displayed are those satisfying the criteria: 

(Maths % >= 60 AND Science % >= 60 AND English % >=60) OR Maths % >=80 

Formulas 
A formula is an expression which calculates the value of a cell. Functions are predefined 

formulas and are already available in Excel. This module teaches you how to enter a formula, 

how to edit a formula, how to display formulas instead of their results, in which order calculations 

occur, how to insert a function, how to copy a formula, and how to refer to a named range 
Insert a Function 

Every function has the same structure. For example, SUM(A1:A4). The name of this function is 
SUM. The part between the brackets (arguments) means we give Excel a range with address 
A1:A4 as input. This function adds the values in cells A1, A2, A3 and A4. It's not easy to 
remember which function and which arguments to use for a specific task. Fortunately, the 
Insert Function feature in Excel helps you with this. To insert a function, execute the following 
steps. 

1. Select the cell that you want to contain the function. 

2. Click the Insert Function button. 

 

The 'Insert Function' dialog box appears. 

3. Search for a function or select a function from a category. For example, choose COUNTIF 
from the 
 Statistical category. 
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4. Click on OK. 

The 'Function Arguments' dialog box appears. 

5. Click the button next to the Range textbox and select the range with address A1:C2. 

6. Enter the criterion. For example, type >5. 

7. Click on OK.  

 

Result. Excel counts the number of cells that are higher than 5. 
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Copy a Formula 

When you copy a formula, Excel adjusts the cell references in the formula to the new location.  
To understand this, execute the following steps. 

1. Enter the formula shown earlier. 

 

2. Select cell A4, right click and then click on Copy. 

 

3. Select cell B4 and click on Paste under the 'Paste Options:' group. 

 

4. Instead of copying the formula to cell B4, you can also drag the formula to cell B4. Click on 

the lower right corner of cell A4 and drag it across to cell B4. This is much easier and gives the 

exact same result! 

 

Result: 
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The formula in cell B4 automatically references the values in Column B. In the next chapter, 
you can learn more about cell references. 

Names in Formulas 

Instead of using cell references in your formulas, you can also refer to a named range. This 
way you can make your formulas easier to understand. Execute the following steps to define a 
name for a range and refer to that name in a formula. 

1. Enter some numbers in range ("A1:A4") and select this range. 

2. On the Formulas tab, click on Define Name. 

 

3. Enter a name. For example, numbers and click on OK. 
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4. There is an even quicker way to name a range. Select the range and simply type the name 
of the range in the name box. 

 

Note: Don't forget to press enter after you've typed the name in the name box. 

5. Now you can refer to this name in your formulas when you want to use this range. 
    For example, sum the numbers. 

Result: 

 

Functions 

01. Sum() 

Use for addition just number values, and ignore text / special character values 
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=Sum(Numbr1,2,3,4,5,…….) 

=Sum(cell:cell)  

 

02. MAX() 

      Show largest number values and ignore text values  

 

 

        

 Values     Maximum  

 120 800 100 120 250 800 
 
=MAX(C4:G4) 

        

 Dates     Maximum  

 01-Jan-98 25-Dec-98 31-Mar-98 
27-Dec-

98 04-Jul-98 27-Dec-98 
 
=MAX(C7:G7) 

        

What Does It Do ?             

This function picks the highest value from a list of data.    

        
Syntax               

=MAX(Range1,Range2,Range3... through to Range30)    

        

Formatting             

No special formatting is needed.      

        

Example               
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In the following example the =MAX() function has been used to find the highest value for 

each region, month and overall.      

        

Sales Jan Feb Mar  

Region 
Max   

North ₹ 5,000 ₹ 6,000 ₹ 4,500  ₹ 6,000  =MAX(C23:E23) 

South ₹ 5,800 ₹ 7,000 ₹ 3,000  ₹ 7,000   
East ₹ 3,500 ₹ 2,000 ₹ 10,000  ₹ 10,000   
West ₹ 12,000 ₹ 4,000 ₹ 6,000  ₹ 12,000   

        
Month 
Max ₹ 12,000 ₹ 7,000 ₹ 10,000     

   

 
=MAX(E23:E26)     

Overall 
Max ₹ 12,000       

 

 
=MAX(C23:E26)       

 

 

03. MIN() 

   Show smallest number values and ignore text values  

=Min(Number1,2,3,4…….) 

=Min(Cell:Cell) 
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04. AVERAGE ()  

Return average by given range  

=AVERAGE (NUMBER1,2,3,4,5,…….) 

=AVERAGE(CELL:CELL) 
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05. COUNT() 

Use for count just number values  

=COUNT(NUMBER1,2,3,4……..) 

=COUNT(CELL:CELL) 

         

 Entries To Be Counted Count     

 10 20 30 3  =COUNT(C4:E4)   

 10 0 30 3  =COUNT(C5:E5)   

 10 -20 30 3  =COUNT(C6:E6)   

 10 01-Jan-88 30 3  =COUNT(C7:E7)   

 10 21:30 30 3  =COUNT(C8:E8)   

 10 0.350357 30 3  =COUNT(C9:E9)   

 10  30 2 
 
=COUNT(C10:E10)   

 10 Hello 30 2 
 
=COUNT(C11:E11)   

 10 #DIV/0! 30 2 
 
=COUNT(C12:E12)   
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What Does It Do ?               

This function counts the number of numeric entries in a list.    
It will ignore blanks, text and errors.      

         
Syntax                 

=COUNT(Range1,Range2,Range3... through to Range30)    

         
Formatting               

No special formatting is needed.       

         

Example                 

The following table was used by a builders merchant to calculate the number of sales  
for various products in each month.      

         

 Item Jan Feb Mar     

 Bricks £1,000          

 Wood   £5,000        

 Glass £2,000  £1,000        

 Metal £1,000          

 Count 3 2 0     

  

 
=COUNT(D29:D32)       

 

06. COUNTA() 

Use for count all values (Text, number, special characters) 

=COUNTA(VALUE1,2,3,4,5……) 

=COUNTA(CELL:CELL) 

         

 Entries To Be Counted Count     

 10 20 30 3  =COUNTA(C4:E4)  

 10 0 30 3  =COUNTA(C5:E5)  

 10 -20 30 3  =COUNTA(C6:E6)  

 10 01-Jan-88 30 3  =COUNTA(C7:E7)  

 10 21:30 30 3  =COUNTA(C8:E8)  

 10 0.42637 30 3  =COUNTA(C9:E9)  

 10   30 2  =COUNTA(C10:E10)  

 10 Hello 30 3  =COUNTA(C11:E11)  

 10 #DIV/0! 30 3  =COUNTA(C12:E12)  

         
What Does It Do ?               

This function counts the number of numeric or text entries in a list.   
It will ignore blanks.        

         

Syntax                 

=COUNTA (Range1, Range2, Range3... through to Range30)    

         
Formatting               

No special formatting is needed.  
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Example                 

The following table was used by a school to keep track of the examinations taken by each pupil. 

Each exam passed was graded as 1, 2 or 3. 
    

A failure was entered as Fail. 
      

         
The school needed to know how many pupils sat each exam. 

   
The school also needed to know how many exams were taken by each pupil. 

 

         
The =COUNTA() function has been used because of its ability to count text and numeric 

entries. 

 

07. COUNTBLANK() 

 

Use for count just blank cells  

=COUNTBLAK(CELL:CELL) 

 
The following table was used by a company which was balloting its workers on whether 

 
the company should have a no smoking policy. 

    

 
Each of the departments in the various factories were questioned. 

  

 
The response to the question could be Y or N. 

    

 
As the results of the vote were collated they were entered in to the table. 

  

 
The =COUNTBLANK() function has been used to calculate the number of departments which 

 
have no yet registered a vote. 

     

         

  Admin Accounts Production Personnel    

 Factory 1 Y N        

 Factory 2   Y Y N    

 Factory 3            

 Factory 4 N   N N    

 Factory 5 Y   Y      

 Factory 6 Y Y Y N    

 Factory 7   N Y      

 Factory 8 N N Y Y    

 Factory 9     Y      

 Factory 10 Y N   Y    

         

    Votes not vet registered :  16 
 
=COUNTBLANK(C32:F41)  

         

    Votes for Yes :  14  =COUNTIF(C32:F41,"Y")  

         

    Votes for No :  10  =COUNTIF(C32:F41,"N")  
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08. COUNTIF() 

Counts the number of cells within a range that meet the given condition 

=COUNTIF(RANGE,”CRITERIA”) 

=COUNTIF(CELL:CELL,”OPERATOR_VALUE”) 

      

 Item Date Cost   

 Brakes 01-Jan-98 80   

 Tyres 10-May-98 25   

 Brakes 01-Feb-98 80   

 Service 01-Mar-98 150   

 Service 05-Jan-98 300   

 Window 01-Jun-98 50   

 Tyres 01-Apr-98 200   

 Tyres 01-Mar-98 100   

 Clutch 01-May-98 250   

      
How many Brake Shoes Have been bought. 2 =COUNTIF(C4:C12,"Brakes") 

How many Tyres have been bought.   3 =COUNTIF(C4:C12,"Tyres") 

How many items cost £100 or above.   5 =COUNTIF(E4:E12,">=100") 

      
Type the name of the item to count. service 2 =COUNTIF(C4:C12,E18) 

      

      
What Does It Do ?         

This function counts the number of items which match criteria set by the user. 

      

Syntax           

=COUNTIF(RangeOfThingsToBeCounted,CriteriaToBeMatched) 

The criteria can be typed in any of the following ways. 
 

To match a specific number, type the number, such as =COUNTIF(A1:A5,100) 

To match a piece of text type the text in quotes, such as =COUNTIF(A1:A5,"Hello") 

To match using operators surround the expression with quotes, such as 

=COUNTIF(A1:A5,">100") 

      
 

09. SUMIF() 

This function adds the value of items which match criteria set by the user. 

 
=SUMIF(RangeOfThingsToBeExamined,CriteriaToBeMatched,RangeOfValuesToTotal) 
 
=SUMIF(B4:B381,"CD-MP3",D4:D381) 



 
 
 
 

33  
 

                               Practical Workbook of MS Excel  

 

 

        

 
        
        
        
        
        
        
        
        
        
        

       

    

    

    
       

     
               

 
 
 
 
What Does It Do ? 

            

This function adds the value of items which match criteria set by the user. 
 

        

Syntax               

=SUMIF(RangeOfThingsToBeExamined,CriteriaToBeMatched,RangeOfValuesToTotal)         

=SUMIF(C4:C12,"Brakes",E4:E12) This examines the names of products in C4:C12.    
It then identifies the entries for Brakes. 

 

   
It then totals the respective figures in E4:E12         

 =SUMIF(E4:E12,">=100") This examines the values in E4:E12. 
 

   
If the value is >=100 the value is added to the total. 
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10. LEFT () 

  

       
  

 
     

  

 
    

  

 
    

  

 
    

  

 
    

  

 
    

  

 
     

  

What Does It Do?             

This function displays a specified number of characters from the left-hand side of a 
 

piece of text. 
      

        

Syntax               

=LEFT(Original Text, NumberOfCharactersRequired) 
   

        

Formatting             

No special formatting is needed. 
     

        

Example               

The following table was used to extract the first name of a person from their full name. 

The =FIND() function was used to locate position of the space between the first and second 

name. 

The length of the first name is therefore the position of the space minus one character. 

The =LEFT() function can now extract the first name based on the position of the space. 
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11. RIGHT ()         

 
      

 

 
     

 

 
     

 

 
     

 

 
     

 

 
     

 

        

 

 

What Does It Do ? 

            

This function displays a specified number of characters from the right-hand side of a 
 

piece of text. 
      

        

Syntax               

=RIGHT(Original Text, NumberOfCharactersRequired) 
    

        

Formatting             

No special formatting is needed. 
     

        

Example               

 

The following table was used to extract the second name of a person from their full name. 

The =FIND() function locates the position of the space between the first and second name. 

The length of the second name is calculated by subtracting the position of the space from 

the overall length of the full name. 
     

The =RIGHT() function can then extract the second name. 
   

        

 
      

 

 
   

 

 
   

 

 

 

 

 

  

   
 

 

12. MID 
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What Does It Do? 

          
 

This function picks out a piece of text from the middle of a text entry. 
   

The function needs to know at what point it should start, and how many characters to pick. 
 

If the number of characters to pick exceeds what is available, only the available characters 
 

will be picked. 
      

        

Syntax             
 

=MID(OriginalText,PositionToStartPicking,NumberOfCharactersToPick) 
   

        

Formatting           
 

No special formatting is needed. 
      

        

Example 1           
 

The following table uses the =MID() function to extract a post code from a branch ID used 
 

by a company. 
      

It is assumed that all branch ID's follow the same format with the letters identifying 
the 

  

postal region being in the 5th and 6th positions. 
     

        

 
    

   

 
   

   

 
   

   

 

 

 

  

   
   

 

 

13. CONCATENATE ()        

  

 
What Does It Do? 

          

 
This function joins separate pieces of text into one item. 

  

       

Syntax             

 =CONCATENATE(Text1,Text2,Text3...Text30) 
   

Up to thirty pieces of text can be joined. 
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Formatting           

      

No special formatting is needed, the result will be shown as normal text. 
 

       

Note             

You can achieve the same result by using the & operator. 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

      

14. REPT 

 
 

What Does It Do ?      
This function repeats a piece of text a specified number of times.  
You need to specify the text to be repeated and how many times to repeat it. 

       
Syntax       
=REPT(TextToRepeat,Repetitions)    
The maximum number of repetitions is 200.    

     

 

15. TODAY 

Show current date  

=TODAY() 

16. NOW 

Show current date and time  

             =NOW() 
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17. INT: 

Return number value before decimal place, INT stand for integer  

=INT(NUMBER )  

     =INT(5.789) → 5 

18 . PROPER: 

Use for convert title case  

=PROPER(TEXT)  

=PROPER(“What is this?”) → What Is This? 

   19. UPPER: 

Use for convert upper case  

=UPPER(TEXT)  

=UPPER(“What is this?”) → WHAT IS THIS? 

20. LOWER: 

Use for convert lower case  

=LOWER(TEXT)  

=LOWER(“What is this?”) → what is this? 

If-Then-Else-Nested If commands 
You can produce different set of results based on slabs, conditions, stages etc. 

It requires logical understating not any programming skills. 

What is the IF Function 

Excel’s IF function is one of simplest and most useful spreadsheet functions. It can fill cell 

fields for you based on evaluating a condition. 

Syntax  

IF(logical_test, value_if_false, value_if_true) 

The thing to note here is the three items between the round brackets of the word IF. These are 
the arguments that the IF function needs. Here's what they mean: 

logical_test 
The first argument is what you want to test for. Is the number in the cell greater than 
80, for example?  

value_if_true 
This is what you want to do if the answer to the first argument is YES. (Award an A 
grade, for example)  

value_if_false 
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This is what you want to do if the answer to the first argument is NO. (Award a FAIL 
grade.)  

If that's not terribly clear, an example may clear things up. Open a new spreadsheet, and do 
the following: 

• Widen the B column a bit, as we'll be putting a message in cell B1  

• Now click in cell A1 and type the number 6  

• Type the following in the formula bar (The right angle bracket after A1 means 

"Greater Than".)  

  =IF(A1 > 5, "Greater than Five", "Less than Five")  

Hit the enter key on your keyboard and your spreadsheet should look like ours below: 

 

Advanced If statement usage: Using multiple criteria with the “AND” and “OR” 

functions 

Sometimes you need to check more than one criteria with the If statement. 

For example:  

Only if the student has grades greater than 80 in Math, greater than 80 in English and 

greater than 80 in History, only then write “good student”, else write “Average Student”. 

The way to implement such a case is using the “AND” function which will include all the 

multiple criteria inside of it.  

This “AND” function, is then put inside the criteria section of the If statement.  

Thus for the above example, the whole function could look something like this: 

=IF(AND(C1>80,D1>80,E1>80) , “Good student” , “Average Student” ) 

Note that the criteria part: AND(C1>80,D1>80,E1>80) will be met only if all three parts of it 

are met. 
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The function “OR” is used in a same manner, but its meaning is slightly different.  

Instead of checking if all its parts is met (as is the case of the “AND” function), it checks if 

at least one of the criteria inside it is met. If it is, then the whole “OR” is considered met. 

Hence, in the following formula: 

=IF(OR(C1>80,D1>80,E1>80) , “Good student” , “Average Student” ) 

It is enough that C1 is really greater than 80 , or that D1 is really greater than 80 or that E1 

is really greater than 80 (or some combination of these three), to have the if function write 

“Good student”. Only if none of these cells (C1, D1 or E1) are greater than 80 the If function 

will result writing “Average Student”. 
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Nested IF Functions: If within if statement is called nested if statement.  

 

Criteria: 

-- if the sales rep has achieved more than $5,000 in sales, he/she is eligible for “full bonus”, 

-- if the sales rep has achieved more than $2,500 in sales, he/she is eligible for “half-bonus”, 

-- If the sales rep has achieved more than $1,000 in sales, he/she is eligible for “quarter bonus”, and 

-- If the sales rep has achieved less than $1,000 in sales,he/she is not eligible for any bonus – “no bonus” 

 

Formula:  

=IF(C3>=5000,"Full Bonus",IF(C3>=2500,"Half-Bonus",IF(C3>=1000,"Quarter Bonus","No Bonus"))) 

 

 

 
 



 
 
 
 

42  
 

                               Practical Workbook of MS Excel  
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Index ()  

This function picks a value from a range of data by looking down a specified number of rows 

and then across a specified number of columns. It can be used with a single block of data, or 

non-continues blocks.  

 Syntax:  

 INDEX(RangeToLookIn,Coordinate)   

This is used when the RangeToLookIn is either a single column or row. The Co-ordinate indicates how 

far down or across to look when picking the data from the range.  Both examples below use the same 

syntax, but the Co-ordinate refers to a row when the range is vertical and a column when the range is 

horizontal.  
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Vlookup / Hlookup 
This is back bone of excel. You have large amount of data placed at different locations and 

you want to merge it based on common values and it’s relevance. Excel's VLOOKUP 

function, which stands for vertical lookup, is used to find specific information that has been 

stored in a spreadsheet table. This tutorial includes step by step instructions of how to use 

Excel's VLOOKUP function. 

Syntax : 

= VLOOKUP (lookup_value, table_array, col_index_num, range_lookup) 

lookup _value: The value you want to find in the first column of the table_array. 

table_array: This is the table of data that VLOOKUP searches to find the information you are 

after. The table_array must contain at least two columns of data. The first column contains the 

lookup_values. 

col_index_num: The number of the column in the table_array that contains the data you want 

returned.  

range_lookup: A logical value (TRUE or FALSE only) that indicates whether you want 

VLOOKUP to find an exact or an approximate match to the lookup_value. Typing False will 

return exact matches only. 
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Suppose we have two table one is master database which contents all order details of all the 

sales rep.  

We have another table where only I have few orderID is given on order id is available in both 

table on basis of order id we want to populate the other details, or we want to match the order 

id.  

 

 

=VLOOKUP(A2,'Order Details'!$A$1:$G$379,3,FALSE)  

  If we want to display meaning full message instead of #N/A, We can use below formula.  

 

=Iferror(VLOOKUP(A2,'Order Details'!$A$1:$G$379,3,FALSE),”Not Found”)  
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➔ Steps to populate multiple columns using single VLOOKUP 

 function. 

 

1) Select all columns.  

  

2)  Type this formula  

 =VLOOKUP (A3,'Material Master'!A:E,{3,5,2},0) 

 

 

 

 

 

 

 

3) Press Ctrl+Shift+Enter to execute array formula.  



 
 
 
 

47  
 

                               Practical Workbook of MS Excel  

 

REVERSE VLOOKUP    
We can apply backwards Vlookup In Reverse Order in Excel. 

Suppose you have Two tables as below screenshot shown. This is master sheet where matching 

column material no is available in right hand side and price which we want to populate is  

available is in left hand side then we can use reverse lookup.  

 

 
 

This is another table where we want to populate price.  

Enter the formula =VLOOKUP (A2, CHOOSE({1,2},'Material Master'!D:D,'Material Master'!A:A),2,0)  

into a B2 cell, and press the Ctrl + Shift + Enter keys at the same  

time. And then you will get the exact price. See screens 
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shot. 

 

 

 

Dynamic Vlookup  

We are going to learn how the MATCH function can be used inside the VLOOKUP function.  

This helps protect the VLOOKUP from returning errors when changes are made to the workbook. 

 

Why Match Function 

Before you combine VLOOKUP and MATCH, you need to understand match function and its working. 

The basic use of MATCH is to find the cell number of the lookup value from a range. 

Syntax: 

MATCH(lookup_value,lookup_array,[match_type]) 

It has mainly three arguments, lookup value, a range to lookup for the value, and the match type to specify 

exact match or an approximate match. 
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HLOOKUP 

Excel's HLOOKUP function, which stands for horizontal lookup, is used to find specific information  

that has been stored in rows in a spreadsheet table.  

Syntax :  

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup) 

lookup _value: The value you want to find in the first column of the table_array.  

table_array: The range of data that HLOOKUP searches to find your information. The 

table_array must contain at least two columns of data. The first column contains the 

lookup_values.  

row_index_num: The number of the row in the table_array that contains the data you want 

returned.  

range_lookup: A logical value (TRUE or FALSE only) that indicates whether you want 

VLOOKUP to find an exact or an approximate match to the lookup_value. Typing False will 

return exact matches only. 

 



 
 
 
 

50  
 

                               Practical Workbook of MS Excel  
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Graphs & Chart 
Graphs offer a visual representation of the data. Instead of having to analyze columns of 

values of spreadsheet, it can interpret the meaning of the data of a single look. A graph 

transmits the messages quickly. With a graph, the data of spreadsheet can be transformed 

to show comparisons, patterns and tendencies.   

 

Creating a Chart 

1) Open data sheet. 

2) Select the data that wish to represent, including the titles of the columns. 

3) Next, it clicks in the Insert Group and, in the sub group Charts, click in the Column 

button. 

 

 

 

 

 

 

 

 

4) The chart will be created and placed near the data table. 

 

Press F11- > Create Column Graph on New Worksheet  

Alt N C Enter -> Create Column Graph On Active Sheet  

Alt       N        N      Enter      ->        Create Line Graph on Active Sheet  
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5) After creating a graph, you can add new elements easily. For example, you can add 

titles to it to offer more information or change the element's position. 

6) When creating a graph, in the Options Tape appears the Graph's Tools, which 

include Design, Distribution and Format groups. In these groups you will find the 

commands necessary to work with the graphs 

 

 
7) When the graph is finished, click outside it. The Graph's Tools will disappear. Click 

within the graph so that they will be displayed again 

8) To change the graph title, Click Layout tab->Chart Title-> Select option and type 

chart title. 

 
 

9) To change the Chart type select the chart area, then right click and select the Change 

 Chart Type menu item. 
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Select Pie chart. 

 
 

Change Data Source: 

1) Click on the design tab-> Select Data Source.  

 

 

Cost
(Rs. Lacs)

Jan-10

Feb-10

Mar-10

Apr-10

May-10

Jun-10

Jul-10

Aug-10

Sep-10
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Change Chart Layout  

1) Click on the design Tab -> Select Layout Group.  

 

 

 

 

Format Chart  
 

1) Select chart -> Click on the format   or right chick on the Chart and choose Format option  
 

 

 

 
Steps to Create Dynamic Graph 

 
1) Click on the developer Tab. 

2)  Click on the Insert and Add Form Control.  
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Draw the check box.  

 

3) Right Click on the Check Box -> Select Format Control.  
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4) Link all the check box to relevant cells. -> Click on the Ok Button.  

 

5) Generate Dynamic Formula.  
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6) Create a graph from Dynamic Formula Generated data.  
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Change No of customer as line chart.  
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7) Finally Hide the Dynamic data.  

 

Hyper / Data Linking 
Hyper & data linking, within or outside Worksheet / Excel File is an important feature of Excel. 

This helps update data automatically or based on user requirements without any additional 

effort to produce combination or results and simulations.If you have a lot of different worksheets 

and want a quick way to jump between them, you can use Hyperlinks. Hyperlinks are those 

underlined bits of text on the internet that lead to web pages 

Link Data to Different Worksheets in Microsoft Excel 
 

Create a index sheet.  

 
 

1) Type Hyper Link Text  

2) Select the Hyperlink Text press Ctrl+ K or Insert Tab-> Hyperlink  
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3) From Insert Hyperlink dialog box select Target Location cell reference like Master Sheet 
 

 
 

Create a hyperlink to a specific location in a workbook 

To link to a location in the current workbook or another workbook, you can either define a 

namefor the cells or use a cell reference. 

1) To use a name, you must name the destination cells in the destination workbook. 

2) On a worksheet of the workbook, click the cell where you want to create a hyperlink. 

3) On the Insert tab, in the Links group, click Hyperlink. 

 

3. Under Link to, do one of the following: 

• To link to a location in your current workbook, click Place in This Document. 

• To link to a location in another workbook, click Existing File or Web Page, locate 

and select the workbook that you want to link to, and then click Defined Names. 

4. Do one of the following: 
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• In the Or select a place in this document box, under Cell Reference, click the 

worksheet that you want to link to, type the cell reference in the Type in the cell 

reference box, and then click OK. 

• In the list under Defined Names, click the name that represents the cells that you 

want to link to, and then click OK. 

5. In the Text to display box, type the text that you want to use to represent the hyperlink. 

6. To display helpful information when you rest the pointer on the hyperlink, click ScreenTip, 

type the text that you want in the ScreenTip text box, and then click OK. 

 

 
 

 

Grouping / Ungrouping 
Have lot of data which needs to be grouped for summarized results and crisp view. No 

problem, grouping and ungrouping feature of Excel will help you group / ungroup data 

with lot of ease and on click of a  mouse. 

Insert a Group 

1.       Select the rows or columns you want to group together. 

2.       Click on the Group button. 

3.       You’re done! 
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Now see the outline symbols and the and buttons. 

You can either click on the + and – buttons to hide or unhide the rows in the group, or you can 
click the outline symbols. 

You can add up to 8 levels to your outline by grouping rows within an existing group. The more 
levels of groups the more outline symbols you will have. 

In the above example we have looked at grouping rows, but you can also group columns in the 
same way. 

 

a. You can Expand a group by clicking on the Show Detail button located in the Outline 
Group. 

b. You can Collapse a group by clicking on the Hide Detail button located in the Outline 
Group. 

Remove a Group (Ungroup) 

1.       Select the rows or columns you want to ungroup. 

2.       Go to the Data tab and click on Ungroup in the Outline group. 

Alternatively if you want to remove all groups go to the Data tab and click on down arrow on 
the ungroup button 
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Copy the Outlined/Visible Cells Data Only 

1.       Group your data to show the level of detail 
 you want to copy. 

2.       Select the range of cells you want to copy. 

3.       CTRL+G to open the Go To window. 

4.       Select Special. 

5.       Click the Visible Cells Only radio button 
and  
click OK. 

6.       Now you can copy and paste. 

Alt +; -> Copy Visible Cells   
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Pivot Table 
 

Excel pivot tables are a feature that you should learn how to use. Instead of analyzing 

countless spreadsheet records, a pivot table can aggregate your information and show a 

new perspective in a few clicks. You can also move columns to rows or vice versa. You 

might think of a pivot table as a user created summary table of your original spreadsheet. 

You create the table by defining which fields to view and how the information should be 

displayed. Based on your field selections, Excel organizes the data so you see a different 

view of your data. 

As example, A sample spreadsheet of 300 order, which includes the following data fields: 

 

• Order Id 

• Order Date 

• Item Type 

• Sales Rep 

• Sales 

• Incentive 

• City 

• Item Description 
 

 

Using Excel pivot tables, you can organize and group the same data in ways that start to answer questions 
such as: 

• Total Sales of Delhi  

• Total Sales of Sales Person A in Mumbai ? 

• Total Order or CD-Mp3  

• Total Sales of December Month 
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Excel pivot tables allow you to group the spreadsheet or external data source by any of your data fields. 

The thumbnail below shows a Total Sales city wise. 

 

 
 

Using a pivot table, I can continue to slice the information by selecting additional fields from the 

PivotTable Field List. For example, I can take the same data and segment by Sales Person 

Wise. 

 

 
 

 

Pivot Table Structures 

In the balloons  above, labelled the main areas of the pivot table. 

(A) PivotTable Field List – this section in the top right displays the fields in your spreadsheet. 

You may check a field or drag it to a quadrant in the lower portion. 
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(2) The lower right quadrants - this area defines where and how the data shows on your pivot 

table. You can have a field show in either a column or row. You may also indicate if the 

information should be counted, summed, averaged, filtered and so on. 

(3) The outlined area to the left is the result of your selections from (A) and (B).  

There are several ways to build a pivot table. Excel has logic that knows the field type and will 
try to place it in the correct row or column if you check the box. For example, numeric data 
such as Sales sum tends to appear to the right in columns. Textual data, such as City would 
appear in rows. 

While you can simply check fields to display and let Excel build your pivot table, I prefer to use 
the “drag and drop” method. This is partly because I like to visualize my data in columns and 
rows. I think it may also be easier if you have fields, which can appear to be numbers like a 
precinct value. 

Steps to create an Excel Pivot Table 

1. Open your original spreadsheet and remove any blank rows or columns. 

2. Make sure each column has a heading, as it will be carried over to the Field List. 

3. Make sure your cells are properly formatted for their data type. 

4. Highlight your data range 

5. Click the Insert tab. 

6. Select the PivotTable button from the Tables group. 

7. Select PivotTable from the list. 

 

The Create PivotTable dialog appears. 
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8. Double-check your Table/Range: value. 

9. Select the radio button for New Worksheet. 

10. Click OK. 

A new worksheet opens with a blank pivot table. You’ll see that the fields from our source 
spreadsheet were carried over to the PivotTable Field List. 

 
 

 

11. Drag an item such as City from the PivotTable Field List down to the Row Labels 

      quadrant.  
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12. The next step is to ask what you would like to know about each city. I’ll drag the Sales  

rap field from the PivotTable Field List to the Column Labels quadrant. This will provide an additional 

column for each city. Note that you won’t see any numerical data. 

 

 

 
 

13. Now Drag Sales Field from the PivotTable Field List to the Value Labels quadrant. 
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You could change the summarization’s formulas by right click on the header to change and  

selecting the Summarize Data By. Menu item. 

 

 
 

If you change the source data sheet, refresh the Pivot table by right click and select the 

Refresh menu item. Or Click on the Option Tab and Refresh. 
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Apply data Grouping in Pivot Table  

Add date check box -> Right Click on the date column  -> Select Group -> Select Year  

 
 

Option-> Option -> Show Report Filter  Pages ->OK  
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Import data from external data sources (Power 

Query) 

The main benefit of connecting to external data is that you can periodically analyze this data in Microsoft 

Office Excel without repeatedly copying the data, which is an operation that can be time-consuming and 

error-prone. After connecting to external data, you can also automatically refresh (or update) your Excel 

workbooks from the original data source whenever the data source is updated with new information. 

Use Excel's Get & Transform (Power Query) experience to import data into Excel from a wide variety of 

data sources. You can then use the Query Editor to edit query steps to shape or transform data. 

 

 

 

Import Data from Web  

Use Excel's Get & Transform (Power Query) experience to connect to a web page and import information  
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Click the Data tab, then  From Other Sources > From Web. 

 

 

In the From Web dialog box, enter a web page URL, then OK. 

 

In this book, we're using this Web Page URL:  

https://en.wikipedia.org/wiki/List_of_states_and_union_territories_of_India_by_population 
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Click on the connect.  
 
Power Query will analyze the web page and load the Navigator pane in Table View. 

If you know which table you want to connect to, then click it from the list. For this example, we 
chose the State & Union Territories table. 

 

Click Edit, and Power Query will load the web data you selected into Power Query Window. 
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Click on Home tab and click Use First Row as Headers  

 

 

Click on Close & Load to Exit from Query window and return to excel sheet.  
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Track Changes Excel  
Shared workbooks allow team members to access and change data as needed during projects. This can 

cause a problem when you need to verify the data, or when discrepancies arise. Microsoft Excel contains 

several tools to help ease your collaboration woes. The track changes function marks the workbook with 

the date, time and name of the editor of each cell. Use track changes on all your shared documents and 

you will know who to contact to verify and correct discrepancies in your data. 

Instructions 

1. Open Microsoft Excel. 

2. Select "Open" from the menu. Find and 

highlight the file where you want to track the 

changes. Click the "Open" button. 

3. Select “Share Workbook” from the “Changes” 

group of the “Review” menu. Check 

the box beside “Allow changes by 

more than one user at the same time” 

in the “Editing” menu. 

4. Select the “Advanced” menu. Press 

“Keep change history for” under the 

“Track changes” group. Type the 

number of days to maintain a history of 

tracked changes in the “days” box. 

5. Click “OK” to apply the changes. Click 

“OK” to save the workbook. 

6. Select “Track Changes” from the 

“Changes” group on the “Review” 

menu.  

7. Click “Highlight Changes.” 

8. Check the box beside “Track changes 

while editing. This also shares your 

workbook.” 

9. Click in the check box next to “When” to select it. Select “All” from the “When” drop-down box. 

10. Click in the check box beside “Who.” Select “Everyone” from the “Who” drop-down box. 



 
 
 
 

77  
 

                               Practical Workbook of MS Excel  

 
11. Check the box next to “Highlight changes on the screen.” Click the “OK” button. 

12. Click the “Save” button to save the file. 

 

How to Accept or Reject Track Changes 

Let us assume you have a received a spreadsheet with changes made by other users. The following 

are the steps to review and accept or reject them. 

1. Select Review > Track Changes > Accept or Reject Changes from the menu. ‘Select Changes 

to Accept or Reject’ window appears. 
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2. Select changes to accept by choosing ‘When’ and ‘Who’ options 

3. Click ‘OK’ button. ‘Accept or Reject changes’ window appears. Review the changes and accept 

or reject them as required. 

 

 

 

 

 

 

 

 

 

 

Macros 
 

Microsoft Excel 2010/2013 in itself a tool which helps users to work with worksheets & 

workbooks with ease.   

This tool is one of the ultimate timesaver, but there are numerous events when you have to do 

repetitive tasks which are of a very little value but consume your precious time; yet engage you 

in a less productive activity, which Excel may do automatically.   

Microsoft Excel 2010/2013 macro is the feature which eliminates or at-least minimize these 

events which take your precious time in repetitive tasks, and you will be able to capitalize this 

time in more productive & strategic activities.  

 

Recording your first Macro 
 

• Microsoft Excel 2010/2013 provides you a very helpful option which enables you to record a 

macro and also modify and run afterwards 

• Microsoft Excel 2010/2013 don’t provide you the macro recording option by default for 

enabling macro recording at first you need to enable the Developer Tab, next slide defines 

step by step procedure to enable Developer Tab 
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Enabling the Developer Tab 

 

• Click on File Button 

 

• Click on  Options 
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• Click on the Customize Ribbon Tab check Developer check box.  

• Click ok  

Once you are done with the process you will have the Developer Tab ready  

 

 

 

• When you record macro Microsoft Excel 2010/2013 provides you with 2 options either you 

can record a macro using Absolute References or Relative References 

• If you go for Absolute References Excel’s behavior will be: 

o You record a macro in Cell A1 type “Excel is Great” format Bold Cell B1 

o Whenever you play / run this macro Excel will always type “Excel is Great” in Cell A1 

and format Bold Cell B1 no matter wherever your cursor is  

 

• You can refer to following tab that you can click on Use Relative References which will 

enable you to record a macro in relative cells, as discussed whenever a relative reference 

macro is executed it will run in-place  
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1. Click on Cell A1 type “Excel is Great” 

2. Select cells from A1:C1 click on Home Tab and click on Merge & Center  

3. Press Bold & Italics 

4. Now click on Developer Tab and click on Stop recording 

 

Run your Macro 

 

You can execute the macro you just recorded by either clicking on the Macro button on the 

Developer Tab or by pressing Alt F8 , you can see the list of Recorded macros in the dialog 

box you can press Run button 

to execute the macro as soonas you press run you can seethat your recorded macro 

willexecute 

 

Edit Macros  

To see what Excel did behind the scenes you can either click on Macros button on Developer 

Tab and select Edit or you can press Alt F11  
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What it looks like 

 

 

 

This is what Excel did behind the scenes, it written the code for you.  You can change the 

code if you want.You can either closethe window or pressAlt F11 again to goback to your 

Excel 

normal screen  
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Assign Macros on Command Button  

 

• Click on the Developer Tab 

• Under Control Group, Click on the insert button & choose 

Button. 

• Create a Button using drag technique.  

• Select the Macros from Assign Macros Dialog box. Or If you 

want to assign macros later first design Button, Right click 

on the button and click on the assign macros. 

 

 

 

 

 
 

 

 

 

 

 

 

 

Security & Protection – for worksheet 

and file 

Security and protection will help you protect your cells, worksheet area, 

worksheet or an excel file from unauthorized or misuse. You can secure your 

confidential data with this feature. 

Select all cell, click on format, format cells…. 

Uncheck the option locked and click ok… 
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Now, select the cells you want to lock for example as per following snapshot…. 

 

Click on format cell and click on locked and ok…. 

 

Click on protect sheet from the following menu… 
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Type the password you want to use for protection / unprotection… 

 

Now when you try to enter the data in protected cells, you will face the following errors…. 

 

To unprotect the sheet and locked cells…click on unprotect sheet as per following and 
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 type password….. 

 

Setting up the file password……click on File Button and save as…. 

 

Click on Tools…General Option…. 
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Type the password you want to put and then save the file…..when you will open it will ask for the password. 
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Data validation 

Suppose you want the user not to enter or to enter some data in some specified 

fields when they are inputting the data for further analysis or use. You can define 

your custom built data validation rules which are easy to implement, use and 

manage as well. 

Path : Data Tab → Data Validation 

 

Data validation in Excel  –Drop down list 

If you want to validate a cell to restrict data entry to values in a drop-down list follow these 
steps: 

1. Select the cell you want to validate.  
2. On the Data tab, in the Data Tools group, 

click Data Validation.  
3. The Data Validation dialog box will open. 

• In the Data Validation dialog box, click the 

Settings tab.  

• Click on the Allow box then select List from the 

drop-down list.  



 
 
 
 

91  
 

                               Practical Workbook of MS Excel  

• Click the Source box and then type the valid values separated by the appropriate list 

separator character depending on your requirement ( usually a comma “,” or semicolon 

“;”). For example if the cell is for a color of a car then you can limit the values by 

entering : Silver, Green, Blue.  

• Instead of typing your list manually, you can also create the list entries by referring to a 

range of cells in the same worksheet or another worksheet in the workbook.  

• To specify the location of the list of valid entries, do one of the following:  

• If the list is in the current worksheet, enter a reference to your list in the Source box, for 

example enter: =$A$1:$A$6. 

• If the list is on a different worksheet, define a name for your list then enter the name 

that you defined for your list in the Source box, for example, enter: =Valid Projects. 

Configure the allowed data for D35 cell: a number between 100 and 

200.   

 

Number Data Validation  

Suppose you want to enter Pin code inside the excel cell as we know pin code must be equal to  6 

character it can’t more be than 6 character or 

less than 6 character and it must be no.  

 

 

http://www.mstipsandtricks.com/tips-and-tricks/ms-office-tips-and-tricks/ms-excel/consolidate-data/figure6.jpg
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• Create an input message for pin code cell. 

 

• Create an error message. 

 

Click ok Button & try to type invalid pin Code you will get the error message.  
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Paste special functions 

You can play with copied data the way you want with this feature which users 

rarely know. 

 
Paste Special allows you to specify that only the entries be copied (without the formatting) or 
that just the formatting be copied (without the entries).  

This page going to explains to you the Excel 2010/2013 paste special options.  

 
To use the Paste Special dialog box 

• Select the range of data you wish to copy.  

• On the Home tab, in the Clipboard group, click Copy icon. 
OR press Ctrl+C.  

• Click the cell where you want to paste the range.  

• On the Home tab, in the Clipboard group, click the down arrow of the Paste icon and click 
the Paste Special option.  

• From the Paste Special dialog box displayed, select the necessary option from the Paste 
section:  
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Each option is explain as follow: 

 

• In the Operation section, select the available suitable option.  

• In the Operation section, select the available suitable option.  

• For example, if you select the Add option, Excel adds the corresponding values in the source 
range and the destination range and replaces the destination range with the new values.  

• The Skip Blanks option prevents Excel from overwriting cell contents in your paste area with 
blank cells from the copied range. It is useful if you're copying a range to another area but 
don't want the blank cells in the copied range to overwrite existing data.  

• The Transpose option can change the orientation of the pasted entries. For example, if the 
original cells' entries run down the rows of a single column of the worksheet, the transposed 
pasted entries will run across the columns of a single row (see steps below).  

 
To use the Transpose option 

• Select the range of data you wish to copy and transpose.  

• On the Home  tab, in the Clipboard group, click Copy icon. 
OR press Ctrl+C.  

• Click the cell where you want to place the range.  

• On the Home tab, in the Clipboard group, click the down arrow of the Paste icon and click 
Transpose.  
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How to Flatten, Repeat, and Fill 

Labels Down in Excel 
Flattening Data 

Many of Excel’s features, such as PivotTables, Charting, AutoFilter, and the Subtotal feature, were 
designed to work with flat data. Flat data is described as data which contains values in all cells within the 
table. All information about the record is derived from the values in the row, and, not from its position within 
the table. It is simple to see the difference visually. So, this screenshot shows data that is not flat: 

 
 
You can see labels are not repeated, and there are cells with missing values. Thus, we must determine 
information about a record based on the position of the row within the table. For example, we know that 
row 39 is for Bay shore Water, but, we only know that row 40 is for Bay shore Water based on its position 
within the table. 

In contrast, flat data contains repeats the labels as needed. This screenshot shows flat data: 

http://www.excel-university.com/wp-content/uploads/20130725a.png
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All cells within the table contain values. All information about a record is contained within the row, and is 
not derived by its position within the table. 

Sometimes we obtain data from an accounting system or from a client that is not flat. We want to use it 
with Excel, and really wish we could easily flatten it. Since this is Excel, there are of course several ways 
to approach this task, but one of the easiest ways is by using a series of built-in commands. 

We’ll start with a summary, and then work through the details. 

Summary 

1. Select the range that you want to flatten – typically, a column of labels 
2. Highlight the empty cells only – hit F5 (GoTo) and select Special > Blanks 
3. Type equals (=) and then the Up Arrow to enter a formula with a direct cell reference to the first data 

label 
4. Instead of hitting enter, hold down Control and hit Enter 
5. To replace the formulas with values, select the whole column, and then Copy / Paste Special > Values 

Details 

Here, we’ll walk through each step, and … I brought screenshots! 

Step 1: 

First, select the range that you’d like to flatten. This is typically a column of labels you want to repeat, 
represented by B39:B62 in the screenshot below: 

http://www.excel-university.com/wp-content/uploads/20130725b.png
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Step 2: 

Next, we need to select only the empty cells within the range. We can simply use the Go To command for 
this. Hit the F5 key on your keyboard to bring up the Go To dialog, as shown below: 

 
  

Next, hit the Special button to bring up the Go To Special dialog. Select the Blanks option, as shown below: 

http://www.excel-university.com/wp-content/uploads/20130725c.png
http://www.excel-university.com/wp-content/uploads/20130725d.png
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Click OK, and Excel will select only the empty/blank cells within the original range, as shown below: 

http://www.excel-university.com/wp-content/uploads/20130725e.png
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Step 3: 

Now, we need to write a formula that pulls the value from the cell above. This is easily accomplished by 
typing an equal sign (=), and then hitting the Up Arrow key on your keyboard. There are other ways, but 
to me, this is the easiest way to write the formula. Now, resist the urge to hit the Enter key!! Do NOT hit 
Enter yet. The resulting formula is shown below: 

http://www.excel-university.com/wp-content/uploads/20130725f.png
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Step 4: 

Now, we need to fill this formula down through all selected (blank) cells. This is done by holding down the 
Control key, and then pressing Enter immediately after writing the formula. If you have written the formula, 
and have already pressed Enter, then, you’ll need to write the formula again, and press Ctrl+Enter instead 
of Enter. 

The Ctrl+Enter shortcut tells Excel to perform two tasks at once. Enter the formula, and, fill it down through 
all selected cells. 

The result of this command is shown below: 

http://www.excel-university.com/wp-content/uploads/20130725g.png
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Step 5: 

Now, all that remains is to replace the formulas with their values. First, select the whole column. Excel 
doesn’t let us perform the next step with multiple ranges selected, so, we need to select a single column 
range. 

Now, we just copy the range using any method you prefer (Ribbon, right-click, keyboard shortcut). Then, 
we do a Paste Special. In the Paste Special dialog box that pops up, we select Values, as shown below: 

  

When we click OK, we are done. We repeat these steps on the Account column, and bam…..flat data, as 
shown below: 

http://www.excel-university.com/wp-content/uploads/20130725h.png
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Notes 

You can typically perform this task on multiple columns at the same time, but, it only works if the first row 
has values for all selected columns, so, just be sure to review and double-check your work. 

Conclusion 
As with just about everything in Excel, there are many different ways to accomplish any given task. I would 
use the approach above if I needed to flatten data occasionally. However, if I needed to flatten data files 
often, then I would probably handle this task with a macro. But, that is a post for another day. 

Hope this approach helps you flatten data files quickly! 

 

 

 

Print settings 
You can take print of enormous data with the way you want. 

http://www.excel-university.com/wp-content/uploads/20130725k.png
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• Click on File Button and then print. 

• Click on preview then click on Page setup 
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1.Navigating in Worksheets and Selecting Cells 

Ctrl+Shift+[+] 
Insert a new row or column (after the current row is selected 
with shift+ space, or column is selected with ctrl+ space 

arrow left, arrow right, arrow up,arrow down Move one cell up, down, left, or right in a worksheet. 

Ctrl+Arrow Keys Moves to the edge of the current data region 

Shift+Arrow Keys Extends the selection of cells by one cell. 

Ctrl+Shift+Arrow Keys 
Extends the selection of cells to the last nonblank cell in the same 
column or row as the active cell, or if the next cell is blank, extends 
the selection to the next nonblank cell 

Backspace 
Deletes one character to the left in the Formula Bar. Also clears the 
content of the active cell. In cell editing mode, it deletes the character 
to the left of the insertion point 

Delete 
Removes the cell contents (data and formulas) from selected cells 
without affecting cell formats or comments. In cell editing mode, it 
deletes the character to the right of the insertion point. 

End 
Moves to the cell in the lower-right corner of the window when 
SCROLL LOCK is turned on. Also selects the last command on the 
menu when a menu or submenu is visible. 

Ctrl+End 
Moves to the last cell on a worksheet, in the lowest used row of the 
rightmost used column. If the cursor is in the formula bar, 
CTRL+END moves the cursor to the end of the text 

Ctrl+Shift+end in worksheet 
Extends the selection of cells to the last used cell on the worksheet 
(lower-right corner). 

Ctrl+Shift+end in formula bar 
Selects all text in the formula bar from the cursor position to the 
end—this does not affect the height of the formula bar. 

Enter Completes a cell entry and selects the cell below 

Shift+Enter Completes a cell entry and selects the cell above. 

Ctrl+Enter Completes a cell entry and stays in the same cell 

Alt+Enter Starts a new line in the same cell 

Esc 

Cancels an entry in the cell or Formula Bar. Closes an open menu or 
submenu, dialog box, or message window. It also closes full screen 
mode when this mode has been applied, and returns to normal 
screen mode to display the Ribbon and status bar again. 

Home 

Moves to the beginning of a row in a worksheet. Moves to the cell in 
the upper-left corner of the window when scroll lock is turned on. 
Selects the first command on the menu when a menu or submenu is 
visible. 

Ctrl+Home Moves to the beginning of a worksheet. 

Ctrl+Shift+Home Extends the selection of cells to the beginning of the worksheet 

Page Down Moves one screen down in a worksheet. 

Alt+Page Down Moves one screen to the right in a worksheet. 

Ctrl+Page Down Moves to the next sheet in a workbook. 
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Ctrl+Shift+Page Down Selects the current and next sheet in a workbook 

Page Up Moves one screen up in a worksheet. 

Alt+Page Up Moves one screen to the left in a worksheet. 

Ctrl+Page Up Moves to the previous sheet in a workbook. 

Ctrl+Shift+Page Up Selects the current and previous sheet in a workbook 

Space 
In a dialog box, performs the action for the selected button, or selects 
or clears a check box. 

Ctrl+Space Selects an entire column in a worksheet. 

Shift+Space Selects an entire row in a worksheet. 

Ctrl+Shift+Space Selects the entire worksheet. 

Tab 
Moves one cell to the right in a worksheet. Moves between unlocked 
cells in a protected worksheet. Moves to the next option or option 
group in a dialog box. 

Shift+Tab 
Moves to the previous cell in a worksheet or the previous option in a 
dialog box. 

Ctrl+Tab Switches to the next tab in dialog box 

Ctrl+Shift+Tab Switches to the previous tab in a dialog box. 

 

2. Format Cells 

Ctrl+1 Format cells dialog. 

Ctrl+b (or ctrl+2) Apply or remove bold formatting. 

Ctrl+i (or ctrl+3) Apply or remove italic formatting. 

Ctrl+u (or ctrl+4) Apply or remove an underline. 

Ctrl+5 Apply or remove strikethrough formatting. 

Ctrl+Shift+& Apply the outline border. 

Ctrl+Shift+_ (underscore) Remove outline borders. 

Ctrl+Shift+F 
Display the Format Cells with Fonts Tab active. Press tab 3x to get to 
font-size. Used to bectrl+shift+p, but that seems just get to the Font 
Tab in 2010. 

Alt+' (apostrophe / single quote) Display the Style dialog box. 

F4 Repeat previous formatting on current cell 
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3. Function keys in Excel  

F1 Displays the Microsoft Office Excel Help task pane. 

Ctrl+F1 
Displays or hides the Ribbon, a component of the Microsoft Office 
Fluent user interface. 

Alt+F1 Creates a chart of the data in the current range. 

Alt+Shift+F1 Inserts a new worksheet. 

F2 
Edits the active cell and positions the insertion point at the end of the 
cell contents. It also moves the insertion point into the Formula Bar 
when editing in a cell is turned off. 

Shift+F2 Adds or edits a cell comment. 

Ctrl+F2 Displays the Print Preview window. 

F3 Displays the Paste Name dialog box. 

Ctrl+F3 Display the Name Manager, create new names. 

Shift+F3 Displays the Insert Function dialog box. 

F4 Repeats the last command or action, if possible. 

Ctrl+F4 Closes the selected workbook window. 

F5 Displays the Go To dialog box. 

Ctrl+F5 Restores the window size of the selected workbook window. 

F6 

Switches between the worksheet, Ribbon, task pane, and Zoom 
controls. In a worksheet that has been split (View menu, Manage 
This Window, Freeze Panes, Split Window command), F6 includes 
the split panes when switching between panes and the Ribbon area. 

Shift+F6 
Switches between the worksheet, Zoom controls, task pane, and 
Ribbon. 

Ctrl+F6 
Switches to the next workbook window when more than one 
workbook window is open. 

F7 
Displays the Spelling dialog box to check spelling in the active 
worksheet or selected range. 

Ctrl+F7 
Performs the Move command on the workbook window when it is not 
maximized. Use the arrow keys to move the window, and when 
finished press ENTER, or ESC to cancel. 

F8 
Turns extend mode on or off. In extend mode, Extended Selection 
appears in the status line, and the arrow keys extend the selection. 

Shift+F8 
Enables you to add a nonadjacent cell or range to a selection of cells 
by using the arrow keys. 

Ctrl+F8 
Performs the Size command (on the Control menu for the workbook 
window) when a workbook is not maximized. 

Alt+F8 Displays the Macro dialog box to create, run, edit, or delete a macro. 

F9 Calculates all worksheets in all open workbooks. 
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Shift+F9 Calculates the active worksheet. 

Ctrl+Alt+F9 
Calculates all worksheets in all open workbooks, regardless of 
whether they have changed since the last calculation. 

Ctrl+Alt+Shift+F9 
Rechecks dependent formulas, and then calculates all cells in all 
open workbooks, including cells not marked as needing to be 
calculated. 

Ctrl+F9 Minimizes a workbook window to an icon. 

F10 Turns key tips on or off. 

Shift+F10 Displays the shortcut menu for a selected item. 

Alt+Shift+F10 
Displays the menu or message for a smart tag. If more than one 
smart tag is present, it switches to the next smart tag and displays its 
menu or message. 

Ctrl+F10 Maximizes or restores the selected workbook window. 

F11 Creates a chart of the data in the current range. 

Shift+F11 Inserts a new worksheet. 

Alt+F11 
Opens the Microsoft Visual Basic Editor, in which you can create a 
macro by using Visual Basic for Applications (VBA). 

F12 Displays the Save As dialog box. 

4. CTRL Combinations in Excel  

Ctrl+Shift+( Unhides any hidden rows within the selection. 

Ctrl+Shift+) Unhides any hidden columns within the selection. 

Ctrl+Shift+& Applies the outline border to the selected cells. 

Ctrl+Shift+_ Removes the outline border from the selected cells. 

Ctrl+Shift+~ Applies the General number format. 

Ctrl+Shift+$ 
Applies the Currency format with two decimal places (negative 
numbers in parentheses). 

Ctrl+Shift+% Applies the Percentage format with no decimal places. 

Ctrl+Shift+^ Applies the Exponential number format with two decimal places. 

Ctrl+Shift+# Applies the Date format with the day, month, and year. 

Ctrl+Shift+@ Applies the Time format with the hour and minute, and AM or PM. 

Ctrl+Shift+! 
Applies the Number format with two decimal places, thousands 
separator, and minus sign (-) for negative values. 

Ctrl+Shift+* 
Selects the current region around the active cell (the data area 
enclosed by blank rows and blank columns). In a PivotTable, it 
selects the entire PivotTable report. 
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Ctrl+Shift+: Enters the current time. 

Ctrl+Shift+" 
Copies the value from the cell above the active cell into the cell or the 
Formula Bar. 

Ctrl+Shift+[+] Displays the Insert dialog box to insert blank cells. 

Ctrl+- Displays the Delete dialog box to delete the selected cells. 

Ctrl+; Enters the current date. 

Ctrl+` 
Alternates between displaying cell values and displaying formulas in 
the worksheet. 

Ctrl+' 
Copies a formula from the cell above the active cell into the cell or 
the Formula Bar. 

Ctrl+1 Displays the Format Cells dialog box. 

Ctrl+2 Applies or removes bold formatting. 

Ctrl+3 Applies or removes italic formatting. 

Ctrl+4 Applies or removes underlining. 

Ctrl+5 Applies or removes strikethrough. 

Ctrl+6 
Alternates between hiding objects, displaying objects, and displaying 
placeholders for objects. 

Ctrl+8 Displays or hides the outline symbols. 

Ctrl+9 Hides the selected rows. 

Ctrl+0 (zero) Hides the selected columns. 

Ctrl+A 

Selects the entire worksheet. If the worksheet contains data, 
CTRL+A selects the current region. Pressing CTRL+A a second time 
selects the current region and its summary rows. Pressing CTRL+A a 
third time selects the entire worksheet. 

Ctrl+Shift+A 
Inserts the argument names and parentheses when the insertion 
point is to the right of a function name in a formula. 

Ctrl+B Applies or removes bold formatting. 

Ctrl+C Copies the selected cells. 

Ctrl+C Followed by another CTRL+C displays the Clipboard. 

Ctrl+D 
Uses the Fill Down command to copy the contents and format of the 
topmost cell of a selected range into the cells below. 

Ctrl+F Displays the Find and Replace dialog box, with the Find tab selected. 

Ctrl+Shift+F Opens the Format Cells dialog box with the Font tab selected. 

Ctrl+G Displays the Go To dialog box. 

Ctrl+H 
Displays the Find and Replace dialog box, with the Replace tab 
selected. 
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Ctrl+I Applies or removes italic formatting. 

Ctrl+K 
Displays the Insert Hyperlink dialog box for new hyperlinks or the Edit 
Hyperlink dialog box for selected existing hyperlinks. 

Ctrl+N Creates a new, blank workbook. 

Ctrl+O Displays the Open dialog box to open or find a file. 

Ctrl+Shift+O Selects all cells that contain comments. 

Ctrl+P Displays the Print dialog box. 

Ctrl+Shift+P Opens the Format Cells dialog box with the Font tab selected. 

Ctrl+R 
Uses the Fill Right command to copy the contents and format of the 
leftmost cell of a selected range into the cells to the right. 

Ctrl+S 
Saves the active file with its current file name, location, and file 
format. 

Ctrl+T Displays the Create Table dialog box. 

Ctrl+U Applies or removes underlining. 

Ctrl+Shift+U Switches between expanding and collapsing of the formula bar. 

Ctrl+V 
Inserts the contents of the Clipboard at the insertion point and 
replaces any selection. Available only after you have cut or copied an 
object, text, or cell contents. 

Ctrl+Alt+V 
Displays the Paste Special dialog box. Available only after you have 
cut or copied an object, text, or cell contents on a worksheet or in 
another program. 

Ctrl+W Closes the selected workbook window. 

Ctrl+X Cuts the selected cells. 

Ctrl+Y Repeats the last command or action, if possible. 

Ctrl+Z 
Uses the Undo command to reverse the last command or to delete 
the last entry that you typed. 

Ctrl+Shift+Z 
Uses the Undo or Redo command to reverse or restore the last 
automatic correction when AutoCorrect Smart Tags are displayed. 

7. Microsoft Clip Organizer main 

Ctrl+Arrow Left/Ctrl+Arrow Right Move forward or backward one word in the Search text box. 

Alt+C Displays the Collection List task pane. 

Alt+S Displays the Search task pane. 

Alt+H Open Help. 

Arrow Keys Move left and right, up and down, among collections or clips. 

Shift+Arrow Keys Select additional clips after one clip has been selected. 
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Ctrl+A Select all clips on the current page. 

Ctrl+C Copy (select a clip and move it to the clipboard). 

Ctrl+V Paste (paste from the clipboard to Clip Organizer). 

Delete Delete selected clip or category. 

Home Move to the beginning of a row and select the first item. 

End Move to the end of a row and select the last item. 

Shift+F10 
Display a shortcut menu for a collection, clip, or link (same as right 
click). 

Esc Exit a dialog box. 

tab and shift+Tab 
Shift focus forward and backward between different areas of a dialog 
box. 

Alt+Space Open the shortcut menu of a dialog box. 

 
8. Work with the Excel Ribbon 

Alt/F10 
Select the active tab of the Ribbon and activate the access keys. . 
Press either of these keys again to move back to the document and 
cancel the access keys. 

Alt/ f10 to select the active tab, and thenarrow 
left /Arrow Right 

Move to another tab of the Ribbon. 

Ctrl+F1 Minimize or restore the Ribbon. 

Shift+F10 Display the shortcut menu for the selected command. 

F6 
Move the focus to select either Active tab of the Ribbon, View Status 
bar at bottom of the window or document 

Alt/ f10, and then tab /Shift+Tab 
Move the focus to each command in the Ribbon, forward or 
backward. 

arrow down, arrow up, arrow left, /Arrow Right Move down, up, left, or right among the items in the Ribbon. 

Space/Enter Activate the selected command or control in the Ribbon. 

Space/Enter Open the selected menu or gallery in the Ribbon. 

Enter 
Activate a command or control in the Ribbon so you can modify a 
value. 

Enter 
Finish modifying a value in a control in the Ribbon, and move focus 
back to the document. 

F1 
Get help on the selected command or control in the Ribbon. (If no 
Help topic is associated with the selected command, the Help table 
of contents for that program is shown instead.) 
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Dashboard  

Excel dashboards and executive reports are powerful, fairly easy to design and a great way to improve 

your Excel and data visualization skills. Dashboard is a collection or all the controls line combo box, List 

Box, Check Box, and radio Button. A dashboard is is nothing but a visual interface. 

Excel offers a set of controls called Form controls, designed specifically for adding UI (User Interface) 

elements directly onto a worksheet. After you place a Form control on a worksheet, you can then 

configure it to perform a specific task. Later in the chapter, we demonstrate how to apply the most useful 

controls to a presentation.  

We can find Excel’s Form controls on the Developer tab, which is initially hidden in Excel 2013. 

To enable the Developer tab, follow these steps: 

 

1. Go to the Ribbon and select the File tab. 

2. To open the Excel Options dialog box, click the Options button. 

3. Click the Customize Ribbon button. 

4. Select the check box next to the Developer tab 

5. Click OK. 
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Figure 1.1 Enabling Developer Tab. 

Now, Select the developer tab and choose the Insert command, as shown in Figure 

 

Figure : 1.2  Form controls and ActiveX controls. 

Form controls 

Here are the nine Form controls that we can add directly to a worksheet (see Figure 1.2). They 
are as follows: 
 

Button: Executes an assigned macro when a user clicks the button. 

Combo Box: Gives a user an expandable list of options from which to choose. 

Check Box: Provides a mechanism for a select/deselect scenario. When selected, it returns a value of 

True. Otherwise, it returns False. 

Spin Button: Enables a user to easily increment or decrement a value by clicking the up and down 

arrows. 

List Box: Gives a user a list of options from which to choose. 

Option Button: Enables a user to toggle through two or more options one at a time. Selecting one 

option automatically deselects the others. 

Scroll Bar: Enables a user to scroll to a value or position using a sliding scale that can be moved by 

clicking and dragging the mouse. 
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Label: Allows you to add text labels to your worksheet. You can also assign a macro to the label, 

effectively using it as a button of sorts. 

Group Box: Typically used for cosmetic purposes, this control serves as a container for groups of 

other controls. 

 

 

 

 

 

 

 

 

 

 

Adding a control to a worksheet 

• Click on combo box on the form control. 

• Draw on worksheet using drag and drop technique.  

 

Button 

Combo Box 
Check Box 

Spin Button List Box 

Option Button 

Group Box  

Label 

Scroll Bar 
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Demonstration of Dynamic Graph using Check Box Control.  

 
8) Click on the developer Tab. 

9) Click on the Insert and Add Form Control.  

 

 
Draw the check box.  

 

10) Right Click on the Check Box -> Select Format Control.  
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11) Link all the check box to relevant cells. -> Click on the Ok Button.  

 

12) Generate Dynamic Formula.  
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13) Create a graph from Dynamic Formula Generated data.  
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Change No of customer as line chart.  

 
 

14) Finally Hide the Dynamic data.  

 

Excel’s Camera Tool 

Excel’s Camera tool enables you to take a live picture of a range of cells that updates dynamically 

while the data in that range updates. If you haven’t ever heard of it, don’t feel too bad. This nifty 

tool has been hidden away in that last few versions of Excel. Although Microsoft has chosen not 

to include this tool in the mainstream Ribbon, it’s actually quite useful for those of us building 

dashboards and reports. 

Finding the Camera tool 
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Before you can use the Camera tool, you have to find it and add it to your Quick Access toolbar. 

Follow these steps to add the Camera tool to the Quick Access toolbar: 

• To go to Excel’s Backstage View, on the Ribbon, click the File tab. 

• To open the Excel Options dialog box, click the Options button. 

• Click the Quick Access Toolbar button. 

• In the Choose Commands From drop-down list box, select Commands Not in the Ribbon. 

• Scroll down the alphabetical list of commands  and find Camera 

• Select Camera Option and Click on the add button.  

• Double click to add it to Quick Access toolbar. 

• Click OK . 
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How to use Camera tool 
 
To use the Camera tool, you simply highlight a range of cells to then capture everything in that 

Range in a live picture. The cool thing about the Camera tool is that you’re not limited to showing 

a single cell’s value like you are with a linked text box. And because the picture is live, any 

updates made to the source range automatically changes the picture. 

Take a moment to walk through this basic demonstration of the Camera tool. you’ll see some simple 

numbers and a chart based on those numbers. The goal here is to create a 

live picture of the range that holds both the numbers and the chart. 
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Select the Graph Range 

On Quick Access Tool Bar Click on the camera tools.  

  

 

Select the Graph  
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A live picture is created using camera tools.  

 

 

Demonstration of List Box, radio Button and Combo Box.  

 

This is sample Pivot Table Report  
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Steps to Create Mini dashboard using Option button, Combo Box and List box 

1) Click on the developer tab.  

 

 

 

 

 

 

 

 

2) Draw Option button given in Figure – Option Button 1.  

3) Rename the option Button like below Image. 

 

 

Figure Option Button 2 

4) Link the option button  

5) Right click on the action button and Select Control table  

6) Click on the Cell Link  and select any cell address.  , Click ok button. Now option button link with 

cell address, it return (1,2,3,4) if you will select first option it will return 1, if you select 2nd option 

button it will return two and so on…. 

 

 

 

 

 

 

Figure - Option Button 1 

Figure Option Button 3 
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7) Copy the header.  

 

 

8) Use this index formula to populate data from left side datatable.  

 

        

 

 

9) Apply index formula for all the representative.  

10) Create a column or line graph on above table.  

 

Figure Option Button 4 

11) Finally it will look like .  
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Figure Option Button 5 

 

 

 

 

 

 
Figure Check Box 1 
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Toggling a chart series on and off using Check box control 

 
Figure Check Box 1 shows the same chart twice. Notice that the top chart contains only one series, with 

a check box offering to Show 2009 Trend data. The bottom chart shows the same chart with 

the check box selected. The on/off nature of the check box control is ideal for interactivity that 

calls for a visible/not visible state 

Automating Your Dashboards and Reports 

 

 

 

 

 

 

 

 

 

  

 

 

We start with the raw data (Samples 12- Form Controls.xlsx) that contains both 2009 

and 2010 data (see Figure Formula Sheet)  In the first column is a cell where the check box control will output 
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its value (cell A12 in this example). This cell will either contain True or False. 

 

Figure Formula Sheet 

 

List Box Control 

 
The list box control allows users to select from a list of predefined choices. The idea is that when 

an item from the list box control is selected, some action is taken with that selection. To add a list 

box to your worksheet, follow these steps: 

 

1. Select the Insert drop-down list under the Developer tab. 

2. Select the list box Form control. 

3. Click the location in your spreadsheet where you want to place your list box. 

4. After you drop the control onto your worksheet, right-click the control and select Format 

Control. 

5. Click the Control tab to see the configuration options, as shown in Figure List Box 1. 

6. In the Input Range setting, identify the range that holds the predefined items you want to 

present as choices in the combo box. 

As you can see in Figure List Box 1, this list box is filled with region selections. 

7. In the Cell Link box, enter the cell where you want the list box to output its value. 

By default, a list box control outputs the index number of the selected item. This means 

if the second item on the list was selected, the number 2 would be output. If the fifth 

item on the list was selected, the number 5 would be output. Notice in Figure list Box 1 that 

this particular control outputs to cell P2. The Selection Type  setting allows users to 

choose more than one selection in the list box. The choices here are Single, Multi, and 

Extended. Always leave this setting on Single, as Multi and Extended work only in the 

VBA  environment. 

8. (Optional) You can check the 3D property if you want the control to have a 3-D 

Appearance. 
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9. Click OK to apply your changes. 

 

 

Figure List Box 1 

Controlling multiple charts with one selector 

One of the more useful ways to use a list box is to control multiple charts with one selector. 

Figure 15-25 illustrates an example of this. As a region selection is made in the list box, all three 

charts are fed the data for that region, adjusting the charts to correspond with the selection 

made. Happily, all this is done without VBA code, just a handful of formulas and a list box. 

 

To create this example, we start with three raw datasets (as shown in Figure List Box 2) that contain 
Three categories of data; Revenues, Net Income %, and Gross Margin. Each dataset contains a 
Separate line for each region. 
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Figure List Box  2 

 

We then add a list box that outputs the index number of the selected item to cell P2  
 

 
Figure List Box  3 
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As you can see in Figure List Box 3 , the CHOOSE formula retrieves the target position number from 

Cell P2 (the cell where the list box outputs the index number of the selected item) and then 

matches that position number to the list of cell references given. The cell references come 

directly from the raw data table. 

 

In the example shown in Figure List box 4, the data that would be returned with this CHOOSE formula 

would be 98741. Why? Because cell P2 contains the number 1, and the first cell reference within 

the CHOOSE formula is cell B7. 

 

 

Figure List Box  4 :  Use the CHOOSE function to capture the correct data corresponding to the selected region. 

 

Combo Box with Macro 

A combo box is a drop-down list from where a user can select an item or fill in his/her own choice. To create a 

combo box in Excel VBA, execute the following steps. 

 

1. On the Developer tab, click Insert. 

2. In the ActiveX Controls group, click Combo Box. 
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3. Drag a combo box on your worksheet. 

 

Note: you can change the name of a control by right clicking on the control (make sure Design Mode is selected) 

and then clicking on Properties. For now, we will leave ComboBox1 as the name of the combo box. 

Create a Workbook Open Event. Code added to the Workbook Open Event will be executed by Excel VBA when 

you open the workbook. 

4. Open the Visual Basic Editor. 

5. Double click on This Workbook in the Project Explorer. 

6. Choose Workbook from the left drop-down list and choose Open from the right drop-down list. 

 

http://www.excel-easy.com/vba/create-a-macro.html#visual-basic-editor
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7. To add items to the combo box, add the following code lines to the Workbook Open Event: 

With Sheet1.ComboBox1 

     .AddItem "Paris" 

    .AddItem "New York" 

    .AddItem "London" 

End With 

Note: use Sheet2 if your combo box is located on the second worksheet, Sheet3 if your combo box is located on 

the third worksheet, etc. If you use these code lines outside the Workbook Open event, you might want to add the 

code lines below before these code lines. The first code line clears the combo box. This way your items won't be 

added multiple times if you execute your code more than once. The second code line clears your own choice. 

ComboBox1.Clear 

ComboBox1.Value = "" 

8. To link this combo box to a cell, right click on the combo box (make sure design mode is selected) and click on 

Properties. Fill in D2 for Linked Cell. 

 

Note: also see the ListFill Range property to fill a combo box with a range of cells. 

9. Save, close and reopen the Excel file. 

Result: 

 

Although in some situations it can be useful to directly place a combo box on your worksheet, a combo box is 

particularly useful when placed on a User form. 

http://www.excel-easy.com/vba/userform.html
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Create a Scroll Bar 

A Scroll Bar is what you need when you have a huge data set and you don’t want it to display your entire screen’s 

How to link a data set to this dynamic scroll bar, such that when a user changes the scroll bar, the data 

accordingly changes.  It comes in handy when you are creating a dashboard, or when you simply want to fit a 

huge list in limited space. 

Create a Scroll Bar Form Control  

The first step is to get your data in place. 

 

Go to Developer Tab –> Insert –> Scroll Bar (Form Control). 

 

1. Click on Scroll Bar (Form Control) button and click anywhere on your worksheet. This will insert a Scroll Bar in 

the excel worksheet. 

2. Right click on the Scroll Bar and click on ‘Format Control’. This will open a Format Control dialogue box. 

3. In Format Control dialogue box go to ‘Control’ tab, and make the following changes: 

o Current Value: 1 

o Minimum Value: 1 

o Maximum Value: 19 (it is 19 here as we display 10 rows at a time. So when the user makes the 

scroll bar value 19, it displays rows 19-28) 

o Incremental Change: 1 

o Page Change: 5 

o Cell Link: $L$3 
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4. Now enter the following formula in the first cell (H4) and then copy it to fill all the other cells: 

=OFFSET(C3,$L$3,0) 

Note that this OFFSET formula is dependent on cell L3, which is linked to the scroll bar. 

 

5. The OFFSET formula uses cell C3 as the reference cell, and offsets it by the values specified by cell L3. Since 

L3 is linked to scroll bar value, when the scroll bar value becomes 1, the formula refers to the first state name. 

When it becomes 2, it refers to the seconds state. 

6. Also, since C3 cell has not been locked, in the second row, the formula becomes=OFFSET (C4,$L$3,0) and 

works the same way. 

 

 

http://trumpexcel.com/excel-functions/excel-offset-function/
http://trumpexcel.com/excel-functions/excel-offset-function/

